Подключаем GNS3 в VMware Player к локальной сети и интернету - АлтунинВВ.Блог - всё об IT-технологиях!
Четверг, 27 августа 2020 14:15

Подключаем GNS3 в VMware Player к локальной сети и интернету

Россия
Оцените материал
(0 голосов)

В прошлой статье, мы рассмотрели установку GNS3 на VMware Player. Сегодня мы предоставим устройствам, запущенным в GNS3, доступ к нашей ЛВС и сети Интернет.

Всё рассмотренное далее, подразумевает, что вы установили и настроили GNS3 согласно предыдущей части.

Давайте определимся с подсетями. Для сети управления GNS3 мы будем использовать подсеть: 

172.16.100.240/28

Зададим адрес usb-адаптеру Ethernet 2 ip-адрес 172.16.100.254 с маской 255.255.255.0

Не забудьте отключить IP6, сняв галочку с IP версии 6 (TCP/IP)

Откроем окно сервера:

2020-08-27_15-03-51.png

Выберем пункт меню Network и нажмем Yes

В открывшемся редакторе приведем настройки к виду:

 2020-08-27_15-18-49.png

Нажмем Ctrl+x и затем Y и затем Enter

После загрузки проверим настройки сети:

2020-08-27_15-20-33.png

Откроем клиент GNS3 и изменим ip-адрес сервера, в настройках, на 192.168.153.19, у вас адрес может быть другим!

2020-08-27_15-21-54.png

VMware player имеет довольно ограниченный функционал для работы с сетью, причём сделано это намеренно. Для настройки GNS3, нам придется обойти это ограничение.

Сперва скачаем полную версию VMware workstation отсюда.

Нам нужно получить из дистрибутива cab-файл, сделаем мы это с помощью 7-Zip:

"C:\Program Files\7-Zip\7z.exe" x VMware-workstation-full-14.1.8-14921873.exe Workstation.cab

Из файла Workstation.cab вы должны извлечь файл vmnetcfg.exe и скопировать его в "C:\Program Files (x86)\VMware\VMware Player\”

После чего запустите vmnetcfg.exe и добавьте новую сеть VMnet2, укажите для нее «Bridget to» - usb-адаптер.

Для Vmnet0 укажите «Bridget to» - встроенный адаптер

Нажмите Ок.

Удалите все скачанные файлы и файл vmnetcfg.exe.

Откроем свойства виртуальной машины и выберем

Network adapter 2 - Custom (VMnet2)

Network adapter 3 - Custom (VMnet0)

Давайте проверим наличие интернета на самом сервере GNS3. Это очень важно, так как при обновлении клиента, нам придется обновлять и серверную часть до новой версии.

Откроем окно виртуальной машины и выберем пункт Shell

Проверим связь до узла ya.ru. Всегда пингуйте именно доменное имя, в этом случае вы не только проверяете наличие пинга, но и правильно ли настроен DNS!

2020-08-27_15-31-18.png

Запустим микротик в GNS3 и откроем Winbox 

Он нам снова доступен, но на этот раз, только по mac-адресу:

2020-08-10_17-09-58.png

Запустим клиент GNS3 и после запуска самого микротика откроем его консоль: 

[admin@MikroTik] >

Добавим ip-адрес интерфейсу ether

/ip address add address=172.16.100.253/28 interface=ether1

Соедините линком mikrotik и cloud1 через ether1 и eth1

Пропингуем ПК с mikrotik

[admin@MikroTik] > /tool ping 172.16.100.254
  current: 113.4Mbps
  average: 116.6Mbps

Связь есть!

Переименуем Микротик на карте в GW1, в GNS3 это можно сделать в настройках самой ноды (подменю Configure)

Изменим имя на самом устройстве: 

[admin@MikroTik] > system identity set name=GW1
[admin@GW1] > system identity print
name: GW1

Сделаем GW1 шлюзом нашей GNS3 подсети 192.16.200.0/28

Для этого установим для ether2 ip-адрес:

/ip address add address=172.16.200.14/28 interface=ether2

В клиенте GNS3 на карту перетащим Ethernet switch и VPCS

Соединим GW1 и Switch1 через Ether2 и Ethernet0

Так же соединим PC1 со Switch1 с любым портом 

Вот что у нас получилось:

 2020-08-10_20-04-03.png

Запустим PC1, откроем его консоль и пропишем IP и шлюз по-умолчанию. 

PC1> ip 172.16.200.1 255.255.255.240 172.16.200.14
Checking for duplicate address...
PC1 : 172.16.200.1 255.255.255.240 gateway 172.16.200.14

Проверим доступность шлюза: 

PC1> ping 172.16.200.14
84 bytes from 172.16.200.14 icmp_seq=1 ttl=64 time=1.088 ms
84 bytes from 172.16.200.14 icmp_seq=2 ttl=64 time=0.516 ms
84 bytes from 172.16.200.14 icmp_seq=3 ttl=64 time=0.370 ms
84 bytes from 172.16.200.14 icmp_seq=4 ttl=64 time=0.596 ms

Проверим доступность нашего ПК: 

PC1> ping 172.16.100.254

172.16.200.254 icmp_seq=1 timeout
172.16.200.254 icmp_seq=2 timeout
172.16.200.254 icmp_seq=3 timeout
172.16.200.254 icmp_seq=4 timeout

 Связи нет, а дело тут в том, что наш ПК не знает, где находится хост 172.16.200.1

На нашем ПК открываем консоль с правами администратора и прописываем  

route -p add 172.16.200.0 mask 255.255.255.240 172.16.100.253
OK

Снова пингуем с PC

 PC1> ping 172.16.100.254

84 bytes from 172.16.100.254 icmp_seq=1 ttl=127 time=0.554 ms
84 bytes from 172.16.100.254 icmp_seq=2 ttl=127 time=0.728 ms
84 bytes from 172.16.100.254 icmp_seq=3 ttl=127 time=0.853 ms
84 bytes from 172.16.100.254 icmp_seq=4 ttl=127 time=0.618 ms

Нужно обязательно сохранить настройки 

PC1> save
Saving startup configuration to startup.vpc
. done

 Но если мы попробуем получить доступ к сети интернет — у нас ничего не выйдет: 

PC1> ping 8.8.8.8

*172.16.200.14 icmp_seq=1 ttl=64 time=0.259 ms (ICMP type:3, code:0, Destination network unreachable)
*172.16.200.14 icmp_seq=2 ttl=64 time=0.279 ms (ICMP type:3, code:0, Destination network unreachable)
*172.16.200.14 icmp_seq=3 ttl=64 time=0.391 ms (ICMP type:3, code:0, Destination network unreachable)
*172.16.200.14 icmp_seq=4 ttl=64 time=0.286 ms (ICMP type:3, code:0, Destination network unreachable)

Это всё от того, что у нашего макета нет доступа к внешней ЛВС

Выключим Mikrotik и увеличим количество адаптеров, щелкнув правой кнопкой на mikrotik и выбрав Configure 

2020-08-27_17-27-13.png

Добавим еще одно  облако и соединим его как показано на рисунке:

2020-08-27_18-02-53.png

Пропишем на микротике ip-адрес из нашей реальной ЛВС

/ip address add address=192.168.0.30/24 interface=ether3

Пропишем маршрут по-умолчанию на микротике через нашу ЛВС 

/ip route gateway=192.168.0.254

Проверим доступ к интернету с PC

PC1> ping 8.8.8.8

8.8.8.8 icmp_seq=1 timeout
8.8.8.8 icmp_seq=2 timeout
8.8.8.8 icmp_seq=3 timeout

 Пинга нет, так как мы не настроили NAT (маскарад) на микротике, давайте пропишем его: 

/ip firewall nat add chain=srcnat action=masquerade out-interface=ether3

Пинг появился

PC1> ping 8.8.8.8

84 bytes from 8.8.8.8 icmp_seq=1 ttl=106 time=137.656 ms
84 bytes from 8.8.8.8 icmp_seq=2 ttl=106 time=136.948 ms
84 bytes from 8.8.8.8 icmp_seq=3 ttl=106 time=136.659 ms
84 bytes from 8.8.8.8 icmp_seq=4 ttl=106 time=136.682 ms
84 bytes from 8.8.8.8 icmp_seq=5 ttl=106 time=136.842 ms

Теперь наша ЛВС GNS3 имеет доступ к интернету.

Конечно, теперь вам необходимо озаботиться настройкой межсетевого экрана на GW1, но это выходит за рамки нашей сегодняшней темы.

Заключение

Сегодня мы с вами рассмотрели настройку GNS3 для доступа к ЛВС и сети Интернет. 

Настроили ethernet usb-адаптер для работы с нвоой сетью.

Исправили настройки сетевых мостов и добавили еще одну виртуальную сеть.

Выделили подсеть для маршрутизаторов и ЛВС GNS3.

Настроили ip-адреса на виртуальном коммутаторе и на виртуальном маршрутизаторе mikrotikGW1

Настроили маршрутизацию между физической и виртуальной сетями.

Добавили виртуальный ПК и соединили его через виртуальный коммутатор с GW1, настроили его для доступа к GW1 и нашей ЛВС.

Настроили NAT на GW1 для обеспечения доступа к сети Интернет устройств из ЛВС GNS3.

Прочитано 208 раз Последнее изменение Четверг, 27 августа 2020 18:04