Настройка DHCP-сервера на MES2324B - АлтунинВВ.Блог - всё об IT-технологиях!
Понедельник, 17 августа 2020 21:07

Настройка DHCP-сервера на MES2324B

Россия
Оцените материал
(0 голосов)

Одним из самых распространённых вопросов при настройке оборудования компании Eltex является - как настроить DHCP?

Как правило провайдер предоставляет клиенту доступ в интернет через маршрутизатор, который в свою очередь выдает ip-адрес через DHCP.

В этом материале мы рассмотрим, как настроить DHCP- сервер на примере MES2324B.

Схема подключений представлена ниже. Обратите внимание, это важно, я произвожу все манипуляции на специально собранном макете, доступ к которому есть только c моего ПК, через USB-сетевую карту. Настройки сети на ПК прописаны вручную. Настраивая DHCP-сервер на оборудовании, подключенном к вашей ЛВС, будьте внимательны! Вы можете нарушить нормальную работу устройств в своей ЛВС подключая к ней еще один DHCP-сервер.

scheme.png

Настройка сервера на MES2324B

Далее я подразумеваю, что коммутатор сброшен до заводских настроек, как это сделать читайте тут.

Вы должны настроить GNS3 согласно этой статье.

Для того, чтобы раздать ip-адрес нам, в первую очередь, потребуется DHCP-сервер. MES2324B является коммутатором третьего уровня, а значит имеет встроенный DHCP-сервер.

Для начала настроим сеть на устройстве 

config
interface vlan 1
 ip address 172.16.200.252 255.255.255.240
 no ip address dhcp
exit

Проверим наличие связи: 

console#ping 172.16.200.254

Pinging 172.16.200.254 with 18 bytes of data:

PING: no reply from 172.16.200.254
PING: timeout
PING: no reply from 172.16.200.254
PING: timeout
PING: no reply from 172.16.200.254
PING: timeout
PING: no reply from 172.16.200.254
PING: timeout

 Связи нет. Всё потому, что у нас GNS3_LAN обслуживается виртуальным коммутатором в режиме сети «внутренняя», так что мы можем получить доступ к GNS3_LAN только с хоста, на котором запущена виртуальная машина.

Давайте это исправим.

Откроем PowerShell от имени админа:

Поменяем тип виртуального коммутатора на External:

Set-VMSwitch GNS3_LAN -NetAdapterName "Ethernet 2"

Проверим пинг с MES2324B

console#ping 172.16.200.254

Pinging 172.16.200.254 with 18 bytes of data: 

18 bytes from 172.16.200.254: icmp_seq=1. time=0 ms
18 bytes from 172.16.200.254: icmp_seq=2. time=0 ms
18 bytes from 172.16.200.254: icmp_seq=3. time=0 ms
18 bytes from 172.16.200.254: icmp_seq=4. time=0 ms
 ----172.16.200.254 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/0/0

Cвязь есть.

Настроим DHCP-сервер. Включим сам сервер:

ip dhcp server

Создадим пул ip-адресов, которые мы будем выдавать клиентам.

ip dhcp pool network LAN_POOL
ip dhcp excluded-address 172.16.100.30 172.16.100.30
address low 172.16.100.1 high 172.16.100.30 255.255.255.224
default-router 172.16.100.30
dns-server 172.16.1.1
exit
exit
wr mem

Обратите внимание, мы выдаем ip-адреса с 1 по 30, но 172.16.100.30 мы назначим MES2324B

Поэтому мы исключаем его из пула командой:

ip dhcp excluded-address 172.16.100.30 172.16.100.30

Так как MES2324B это L3-коммутатор, он может работать и как маршрутизатор, так что назначим ему ip-адрес, чтобы устройства из подсети 172.16.100.0/27 могли его видеть.

config
interface vlan 1
 ip address 172.16.100.30 255.255.255.224
exit

Теперь проверим конфигурацию нашего коммутатора:

sh running-config
ip dhcp server
ip dhcp excluded-address 172.16.100.30 172.16.100.30
ip dhcp pool network LAN_POOL
address low 172.16.100.1 high 172.16.100.30 255.255.255.224
default-router 172.16.100.30
dns-server 172.16.1.1
exit
!
interface vlan 1
 ip address 172.16.100.30 255.255.255.224
 ip address 172.16.200.252 255.255.255.240
 no ip address dhcp
exit
!
!
end

Вы можете назначить несколько ip-адресов коммутатору.

Давайте перенастроим GW1, для этого сбросим его до заводских настроек:

/system reset-configuration

Теперь зайдите на него через консоль, введите логин admin, пароль пустой, скопируйте конфигурацию, приведенную ниже и вставьте её в окно консоли, щелкнув правой кнопкой мыши:

/interface ethernet
set [ find default-name=ether1 ] disable-running-check=no
set [ find default-name=ether2 ] disable-running-check=no
set [ find default-name=ether3 ] disable-running-check=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-server
add interface=ether2 name=server1
/ip address
add address=172.16.200.253/28 interface=ether1 network=172.16.200.240
add address=172.16.200.30/27 interface=ether2 network=172.16.200.0

Проверим доступность GW1 после перенастройки с коммутатора:

console#ping 172.16.200.253
Pinging 172.16.200.253 with 18 bytes of data:

18 bytes from 172.16.200.253: icmp_seq=1. time=10 ms
18 bytes from 172.16.200.253: icmp_seq=2. time=0 ms
18 bytes from 172.16.200.253: icmp_seq=3. time=0 ms
18 bytes from 172.16.200.253: icmp_seq=4. time=0 ms

----172.16.200.253 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/2/10

Если мы сейчас проверим список ip-адресов на GW1 мы обнаружим, что наш маршрутизатор уже получил новый ip-адрес:

[admin@MikroTik] > /ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE
 0   172.16.200.253/28  172.16.200.240  ether1
 1   172.16.200.30/27   172.16.200.0    ether2
 2 D 172.16.100.1/27    172.16.100.0    ether1

Всё потому, что в конфигурации по умолчанию уже прописан DHCP-клиент.

Проверим DHCP-сервер на виртуальных PC в GNS3

Удалим облако Internet в GNS3 клиенте и добавим два VPCS и один Ethernet switch.

Перекоммутируем как указанно на рисунке:

2020-08-17_20-01-18-.png

Щёлкнем правой кнопкой на PC3 и выберем «Edit config». Приведем файл к виду:

# This the configuration for PC3

set pcname PC3
dhcp

 Повторим для PC4

Запустим оба устройства.

Проверим конфигурацию устройств:

Для PC3: 

DORA IP 172.16.100.2/27 GW 172.16.100.30

PC3> sh ip

NAME        : PC3[1]
IP/MASK     : 172.16.100.2/27
GATEWAY     : 172.16.100.30
DNS         : 172.16.1.1
DHCP SERVER : 172.16.100.30
DHCP LEASE  : 86386, 86400/43200/75600
MAC         : 00:50:79:66:68:02
LPORT       : 20024
RHOST:PORT  : 127.0.0.1:20025
MTU:        : 1500

Для PC4: 

DORA IP 172.16.100.3/27 GW 172.16.100.30

PC4> sh ip

NAME        : PC4[1]
IP/MASK     : 172.16.100.3/27
GATEWAY     : 172.16.100.30
DNS         : 172.16.1.1
DHCP SERVER : 172.16.100.30
DHCP LEASE  : 86391, 86400/43200/75600
MAC         : 00:50:79:66:68:03
LPORT       : 20026
RHOST:PORT  : 127.0.0.1:20027
MTU:        : 1500

 Наш DHCP-сервер настроен и работает.

Теперь давайте пропишем статические адреса для наших устройств:

172.16.100.10 для GW1

172.16.100.20 для PC3

172.16.100.21 для PC4

Соберем необходимую информацию, а именно mac-адреса устройств.

Обратите внимание! Ваши mac-адреса будут отличаться от моих!

GW1:

/interface ethernet print
Flags: X - disabled, R - running, S - slave
 #    NAME                                MTU MAC-ADDRESS       ARP
 0 R  ether1                             1500 0C:FE:C2:70:7D:00 enabled
 1 R  ether2                             1500 0C:FE:C2:70:7D:01 enabled
 2    ether3                             1500 0C:FE:C2:70:7D:02 enabled

Мы используем ether1 - 0C:FE:C2:70:7D:00

PC3:

PC3> sh ip
NAME        : PC3[1]
IP/MASK     : 172.16.100.2/27
GATEWAY     : 172.16.100.30
DNS         : 172.16.1.1
DHCP SERVER : 172.16.100.30
DHCP LEASE  : 86018, 86400/43200/75600
MAC         : 00:50:79:66:68:02
LPORT       : 20024
RHOST:PORT  : 127.0.0.1:20025
MTU:        : 1500

MAC устройства - 00:50:79:66:68:02

Для PC4:

PC4> sh ip

NAME        : PC4[1]
IP/MASK     : 172.16.100.3/27
GATEWAY     : 172.16.100.30
DNS         : 172.16.1.1
DHCP SERVER : 172.16.100.30
DHCP LEASE  : 86391, 86400/43200/75600
MAC         : 00:50:79:66:68:03
LPORT       : 20026
RHOST:PORT  : 127.0.0.1:20027
MTU:        : 1500

MAC устройства - 00:50:79:66:68:03

На MES2324B пропишем пул статических адресов:

ip dhcp pool host GW1
address 172.16.100.10 255.255.255.224 hardware-address 0C:FE:C2:70:7D:00
client-name GW1
exit
ip dhcp pool host PC3
address 172.16.100.20 255.255.255.224 hardware-address 00:50:79:66:68:02
client-name PC3
exit
ip dhcp pool host PC4
address 172.16.100.21 255.255.255.224 hardware-address 00:50:79:66:68:03
client-name PC4
exit

Обновим ip-адрес на mikrotik

/ip dhcp-client release 0

Проверим какой адрес он получил на этот раз: 

/ip dhcp-client release 0
Проверим какой адрес он получил на этот раз:
/ip address print
Flags: X - disabled, I - invalid, D - dynamic
 #   ADDRESS            NETWORK         INTERFACE
 0   172.16.200.253/28  172.16.200.240  ether1
 1   172.16.200.30/27   172.16.200.0    ether2
 2 D 172.16.100.10/27   172.16.100.0    ether1

 Прекрасно, теперь проверим PC3 и PC4, просто перезапустим каждое из устройств и заново войдем в консоль:

PC3> sh ip IP 172.16.100.20/27
NAME        : PC3[1]
IP/MASK     : 172.16.100.20/27

PC4> sh ip
NAME        : PC4[1]
IP/MASK     : 172.16.100.21/27

Вот и всё, мы настроили DHCP-сервер на MES2324B. В документации к MES2300 вы найдете дополнительные опции.

Скачать готовый проект для GNS3 вы можете здесь.

Заключение

Сегодня мы рассмотрели настройку DHCP-сервера на MES2324B.

Была проведена перенастройка маршрутизатора GW1 и добавлены виртуальные ПК в GNS3 сеть.

Проверена раздача ip-адресов на эти устройства и на GW1.

Настроен статический пул DHCP для GW1, PC3 и PC4.

В следующей статье мы рассмотрим настройку DHCP-сервера на ESR-200-FSTEC.

Прочитано 282 раз Последнее изменение Вторник, 18 августа 2020 14:29