Настройка LAG в Eltex MES2348B - АлтунинВВ.Блог - всё об IT-технологиях!
Четверг, 01 октября 2020 19:00

Настройка LAG в Eltex MES2348B

Россия
Оцените материал
(0 голосов)

Коммутаторы доступа и маршрутизаторы как, правило имеют довольно большую пропускную способность, например, у MES2348B она равна 123 Гбит/с.

Но это относиться к объему, который устройство способно пропустить через себя. С физическим портами коммутатора всё обстоит всё печальней, максимум на что мы можем рассчитывать – 10 Гбит/с через SFP+ порты. Но даже этого может быть мало, так как по сути 10 Гбит/с это десять пользователей по 1 Гбит/с и всё, канал забит полностью. Хотя, как правило, такого не происходит, но пиковая нагрузка от 48 пользователей, может быть даже выше 10 Гбит/с, а это означает проблемы с пингом и доступностью сервисов сети.

Для решения этой проблемы была создана технология LAG – Link Aggregation Channel и протокол LACP – Link Aggregation Control Protocol.

В этой статье мы рассмотрим настройку LAG на двух MES2348B

Так как нам нужно протестировать ширину канала больше 1Гбит/с, нам понадобиться сетевой адаптер на 10Гбит\с. Такие у меня есть только на серверах, так что, для теста, буду использовать их.

Для теста я буду использовать SFP+ 10GBase-T модули для подключения к серверам.

Сервера подключим через SFP+ порты к разным коммутаторам. Один в порт 1 верхнего – он будет верхний, второй в порт 1 нижнего – он будет нижний.

Схема у нас будет такой

MES-LAG.png

Настроим сеть:

На верхнем – 100.64.0.8/24

На нижнем – 100.64.0.3/24

Проверим пинг, чтобы проверить корректность подключения.

Коммутаторы соединим между собой через порт 23.

Для тестирования получившегося канала мы будем использовать утилиту iperf

Для начала скачиваем её с сайта - https://iperf.fr/iperf-download.php

Для этой статьи скачаем этот файл - https://iperf.fr/download/windows/iperf-3.1.3-win64.zip

Распаковываем архив на сервера в папку c:\iperf

Открываем консоль и вводим

cd c:\iperf

Теперь на верхнем запускаем

iperf3 –s

И только потом на нижнем запускаем

Iperf3 –c 172.16.1.100

C:\iperf>iperf3.exe -c 100.64.0.8
Connecting to host 100.64.0.8, port 5201
[  4] local 100.64.0.3 port 61734 connected to 100.64.0.8 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   112 MBytes   935 Mbits/sec
[  4]   1.00-2.00   sec   113 MBytes   944 Mbits/sec
[  4]   2.00-3.00   sec   113 MBytes   947 Mbits/sec
[  4]   3.00-4.00   sec   113 MBytes   946 Mbits/sec
[  4]   4.00-5.00   sec   113 MBytes   945 Mbits/sec
[  4]   5.00-6.00   sec   113 MBytes   946 Mbits/sec
[  4]   6.00-7.00   sec   113 MBytes   946 Mbits/sec
[  4]   7.00-8.00   sec   113 MBytes   946 Mbits/sec
[  4]   8.00-9.00   sec   113 MBytes   946 Mbits/sec
[  4]   9.00-10.00  sec   112 MBytes   939 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.10 GBytes   944 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.10 GBytes   944 Mbits/sec                  receiver

iperf Done.

Работает, скорость у нас в пределах 1 Гбит/с.

Теперь давайте настроим лаг на портах 22-23 наших коммутаторов.

Прежде чем соединять коммутаторы через порты 22, нужно настроить на них LAG, пропишем и на верхнем и нижнем:

config
interface port-channel 1
description LAG2000Mbits
exit

interface GigabitEthernet 1/0/23
channel-group 1 mode auto
lacp port-priority 1
ex
interface GigabitEthernet 1/0/22
channel-group 1 mode auto
lacp port-priority 2
ex	
ex	
wr mem

Соединяем коммутаторы дополнительно через порт 23 и проверяем пинг. Всё работает.

Проверяем канал: 

C:\iperf>iperf3.exe -c 100.64.0.8
Connecting to host 100.64.0.8, port 5201
[  4] local 100.64.0.3 port 61779 connected to 100.64.0.8 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   113 MBytes   946 Mbits/sec
[  4]   1.00-2.00   sec   113 MBytes   947 Mbits/sec
[  4]   2.00-3.00   sec   112 MBytes   941 Mbits/sec
[  4]   3.00-4.00   sec   113 MBytes   946 Mbits/sec
[  4]   4.00-5.00   sec   113 MBytes   947 Mbits/sec
[  4]   5.00-6.00   sec   113 MBytes   945 Mbits/sec
[  4]   6.00-7.00   sec   113 MBytes   947 Mbits/sec
[  4]   7.00-8.00   sec   113 MBytes   946 Mbits/sec
[  4]   8.00-9.00   sec   113 MBytes   944 Mbits/sec
[  4]   9.00-10.00  sec   113 MBytes   945 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.10 GBytes   945 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.10 GBytes   945 Mbits/sec                  receiver

А ничего не изменилось. Почему? Дело в том, что под Windows есть определённые ограничения, которые мы не сможем превысить, предавая информацию в один поток, в данном случае, порог в 1Гбит/с.

Для того, чтобы обойти это ограничение запустим iperf3 с новыми параметрами 

C:\iperf>iperf3.exe -c 100.64.0.8 -b 10G -P 10
Connecting to host 100.64.0.8, port 5201
[  4] local 100.64.0.3 port 61956 connected to 100.64.0.8 port 5201
[  6] local 100.64.0.3 port 61957 connected to 100.64.0.8 port 5201
[  8] local 100.64.0.3 port 61958 connected to 100.64.0.8 port 5201
[ 10] local 100.64.0.3 port 61959 connected to 100.64.0.8 port 5201
[ 12] local 100.64.0.3 port 61960 connected to 100.64.0.8 port 5201
[ 14] local 100.64.0.3 port 61961 connected to 100.64.0.8 port 5201
[ 16] local 100.64.0.3 port 61962 connected to 100.64.0.8 port 5201
[ 18] local 100.64.0.3 port 61963 connected to 100.64.0.8 port 5201
[ 20] local 100.64.0.3 port 61964 connected to 100.64.0.8 port 5201
[ 22] local 100.64.0.3 port 61965 connected to 100.64.0.8 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  12.1 MBytes   102 Mbits/sec
[  6]   0.00-1.00   sec  11.1 MBytes  93.2 Mbits/sec
[  8]   0.00-1.00   sec  10.9 MBytes  91.2 Mbits/sec
[ 10]   0.00-1.00   sec  11.4 MBytes  95.3 Mbits/sec
[ 12]   0.00-1.00   sec  11.8 MBytes  98.5 Mbits/sec
[ 14]   0.00-1.00   sec  13.4 MBytes   112 Mbits/sec
[ 16]   0.00-1.00   sec  13.8 MBytes   115 Mbits/sec
[ 18]   0.00-1.00   sec  4.25 MBytes  35.6 Mbits/sec
[ 20]   0.00-1.00   sec  11.6 MBytes  97.4 Mbits/sec
[ 22]   0.00-1.00   sec  13.4 MBytes   112 Mbits/sec
[SUM]   0.00-1.00   sec   114 MBytes   952 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   1.00-2.00   sec  11.4 MBytes  95.4 Mbits/sec
[  6]   1.00-2.00   sec  11.6 MBytes  97.5 Mbits/sec
[  8]   1.00-2.00   sec  10.4 MBytes  87.0 Mbits/sec
[ 10]   1.00-2.00   sec  11.4 MBytes  95.4 Mbits/sec
[ 12]   1.00-2.00   sec  12.1 MBytes   102 Mbits/sec
[ 14]   1.00-2.00   sec  12.0 MBytes   101 Mbits/sec
[ 16]   1.00-2.00   sec  12.6 MBytes   106 Mbits/sec
[ 18]   1.00-2.00   sec  7.62 MBytes  63.9 Mbits/sec
[ 20]   1.00-2.00   sec  12.9 MBytes   108 Mbits/sec
[ 22]   1.00-2.00   sec  11.0 MBytes  92.3 Mbits/sec
[SUM]   1.00-2.00   sec   113 MBytes   948 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   2.00-3.00   sec  13.2 MBytes   111 Mbits/sec
[  6]   2.00-3.00   sec  9.75 MBytes  81.9 Mbits/sec
[  8]   2.00-3.00   sec  12.8 MBytes   107 Mbits/sec
[ 10]   2.00-3.00   sec  11.5 MBytes  96.5 Mbits/sec
[ 12]   2.00-3.00   sec  12.4 MBytes   104 Mbits/sec
[ 14]   2.00-3.00   sec  10.4 MBytes  87.1 Mbits/sec
[ 16]   2.00-3.00   sec  10.6 MBytes  89.2 Mbits/sec
[ 18]   2.00-3.00   sec  8.25 MBytes  69.3 Mbits/sec
[ 20]   2.00-3.00   sec  12.2 MBytes   103 Mbits/sec
[ 22]   2.00-3.00   sec  12.1 MBytes   102 Mbits/sec
[SUM]   2.00-3.00   sec   113 MBytes   951 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   3.00-4.00   sec  11.9 MBytes  99.6 Mbits/sec
[  6]   3.00-4.00   sec  11.9 MBytes  99.6 Mbits/sec
[  8]   3.00-4.00   sec  12.5 MBytes   105 Mbits/sec
[ 10]   3.00-4.00   sec  11.8 MBytes  98.5 Mbits/sec
[ 12]   3.00-4.00   sec  12.2 MBytes   103 Mbits/sec
[ 14]   3.00-4.00   sec  10.6 MBytes  89.1 Mbits/sec
[ 16]   3.00-4.00   sec  12.1 MBytes   102 Mbits/sec
[ 18]   3.00-4.00   sec  8.38 MBytes  70.2 Mbits/sec
[ 20]   3.00-4.00   sec  10.5 MBytes  88.1 Mbits/sec
[ 22]   3.00-4.00   sec  11.4 MBytes  95.4 Mbits/sec
[SUM]   3.00-4.00   sec   113 MBytes   950 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   4.00-5.00   sec  11.1 MBytes  93.3 Mbits/sec
[  6]   4.00-5.00   sec  12.6 MBytes   106 Mbits/sec
[  8]   4.00-5.00   sec  12.8 MBytes   107 Mbits/sec
[ 10]   4.00-5.00   sec  11.0 MBytes  92.3 Mbits/sec
[ 12]   4.00-5.00   sec  12.4 MBytes   104 Mbits/sec
[ 14]   4.00-5.00   sec  11.4 MBytes  95.4 Mbits/sec
[ 16]   4.00-5.00   sec  12.0 MBytes   101 Mbits/sec
[ 18]   4.00-5.00   sec  8.00 MBytes  67.1 Mbits/sec
[ 20]   4.00-5.00   sec  11.9 MBytes  99.6 Mbits/sec
[ 22]   4.00-5.00   sec  10.1 MBytes  84.9 Mbits/sec
[SUM]   4.00-5.00   sec   113 MBytes   950 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   5.00-6.00   sec  10.6 MBytes  89.1 Mbits/sec
[  6]   5.00-6.00   sec  12.0 MBytes   101 Mbits/sec
[  8]   5.00-6.00   sec  11.0 MBytes  92.3 Mbits/sec
[ 10]   5.00-6.00   sec  11.6 MBytes  97.5 Mbits/sec
[ 12]   5.00-6.00   sec  12.4 MBytes   104 Mbits/sec
[ 14]   5.00-6.00   sec  10.8 MBytes  90.2 Mbits/sec
[ 16]   5.00-6.00   sec  11.5 MBytes  96.5 Mbits/sec
[ 18]   5.00-6.00   sec  12.0 MBytes   101 Mbits/sec
[ 20]   5.00-6.00   sec  10.5 MBytes  88.1 Mbits/sec
[ 22]   5.00-6.00   sec  10.5 MBytes  88.1 Mbits/sec
[SUM]   5.00-6.00   sec   113 MBytes   947 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   6.00-7.00   sec  12.0 MBytes   101 Mbits/sec
[  6]   6.00-7.00   sec  12.8 MBytes   107 Mbits/sec
[  8]   6.00-7.00   sec  11.6 MBytes  97.5 Mbits/sec
[ 10]   6.00-7.00   sec  12.4 MBytes   104 Mbits/sec
[ 12]   6.00-7.00   sec  11.5 MBytes  96.5 Mbits/sec
[ 14]   6.00-7.00   sec  10.6 MBytes  89.1 Mbits/sec
[ 16]   6.00-7.00   sec  12.5 MBytes   105 Mbits/sec
[ 18]   6.00-7.00   sec  8.00 MBytes  67.1 Mbits/sec
[ 20]   6.00-7.00   sec  11.5 MBytes  96.5 Mbits/sec
[ 22]   6.00-7.00   sec  10.5 MBytes  88.1 Mbits/sec
[SUM]   6.00-7.00   sec   113 MBytes   951 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   7.00-8.00   sec  10.8 MBytes  90.0 Mbits/sec
[  6]   7.00-8.00   sec  12.8 MBytes   107 Mbits/sec
[  8]   7.00-8.00   sec  10.4 MBytes  86.9 Mbits/sec
[ 10]   7.00-8.00   sec  11.6 MBytes  97.4 Mbits/sec
[ 12]   7.00-8.00   sec  11.2 MBytes  94.2 Mbits/sec
[ 14]   7.00-8.00   sec  12.1 MBytes   102 Mbits/sec
[ 16]   7.00-8.00   sec  11.0 MBytes  92.1 Mbits/sec
[ 18]   7.00-8.00   sec  11.4 MBytes  95.3 Mbits/sec
[ 20]   7.00-8.00   sec  9.62 MBytes  80.6 Mbits/sec
[ 22]   7.00-8.00   sec  12.2 MBytes   103 Mbits/sec
[SUM]   7.00-8.00   sec   113 MBytes   947 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   8.00-9.00   sec  11.1 MBytes  93.5 Mbits/sec
[  6]   8.00-9.00   sec  11.4 MBytes  95.6 Mbits/sec
[  8]   8.00-9.00   sec  11.9 MBytes  99.8 Mbits/sec
[ 10]   8.00-9.00   sec  12.0 MBytes   101 Mbits/sec
[ 12]   8.00-9.00   sec  12.2 MBytes   103 Mbits/sec
[ 14]   8.00-9.00   sec  10.9 MBytes  91.4 Mbits/sec
[ 16]   8.00-9.00   sec  12.8 MBytes   107 Mbits/sec
[ 18]   8.00-9.00   sec  8.00 MBytes  67.2 Mbits/sec
[ 20]   8.00-9.00   sec  11.6 MBytes  97.7 Mbits/sec
[ 22]   8.00-9.00   sec  11.1 MBytes  93.5 Mbits/sec
[SUM]   8.00-9.00   sec   113 MBytes   949 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[  4]   9.00-10.00  sec  12.0 MBytes   101 Mbits/sec
[  6]   9.00-10.00  sec  12.0 MBytes   101 Mbits/sec
[  8]   9.00-10.00  sec  11.9 MBytes  99.6 Mbits/sec
[ 10]   9.00-10.00  sec  14.0 MBytes   117 Mbits/sec
[ 12]   9.00-10.00  sec  13.0 MBytes   109 Mbits/sec
[ 14]   9.00-10.00  sec  12.0 MBytes   101 Mbits/sec
[ 16]   9.00-10.00  sec  11.6 MBytes  97.5 Mbits/sec
[ 18]   9.00-10.00  sec  5.00 MBytes  41.9 Mbits/sec
[ 20]   9.00-10.00  sec  11.8 MBytes  98.5 Mbits/sec
[ 22]   9.00-10.00  sec  10.0 MBytes  83.8 Mbits/sec
[SUM]   9.00-10.00  sec   113 MBytes   950 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   116 MBytes  97.5 Mbits/sec                  sender
[  4]   0.00-10.00  sec   116 MBytes  97.3 Mbits/sec                  receiver
[  6]   0.00-10.00  sec   118 MBytes  98.9 Mbits/sec                  sender
[  6]   0.00-10.00  sec   118 MBytes  98.7 Mbits/sec                  recei17:4
[  8]   0.00-10.00  sec   116 MBytes  97.3 Mbits/sec                  sender
[  8]   0.00-10.00  sec   116 MBytes  97.1 Mbits/sec                  receiver
[ 10]   0.00-10.00  sec   119 MBytes  99.5 Mbits/sec                  sender
[ 10]   0.00-10.00  sec   118 MBytes  99.3 Mbits/sec                  receiver
[ 12]   0.00-10.00  sec   121 MBytes   102 Mbits/sec                  sender
[ 12]   0.00-10.00  sec   121 MBytes   102 Mbits/sec                  receiver
[ 14]   0.00-10.00  sec   114 MBytes  95.7 Mbits/sec                  sender
[ 14]   0.00-10.00  sec   114 MBytes  95.6 Mbits/sec                  receiver
[ 16]   0.00-10.00  sec   120 MBytes   101 Mbits/sec                  sender
[ 16]   0.00-10.00  sec   120 MBytes   101 Mbits/sec                  receiver
[ 18]   0.00-10.00  sec  80.9 MBytes  67.8 Mbits/sec                  sender
[ 18]   0.00-10.00  sec  80.7 MBytes  67.7 Mbits/sec                  receiver
[ 20]   0.00-10.00  sec   114 MBytes  95.7 Mbits/sec                  sender
[ 20]   0.00-10.00  sec   114 MBytes  95.5 Mbits/sec                  receiver
[ 22]   0.00-10.00  sec   112 MBytes  94.3 Mbits/sec                  sender
[ 22]   0.00-10.00  sec   112 MBytes  94.1 Mbits/sec                  receiver
[SUM]   0.00-10.00  sec  1.11 GBytes   949 Mbits/sec                  sender
[SUM]   0.00-10.00  sec  1.10 GBytes   948 Mbits/sec                  receiver

iperf Done.

Снова неудача.

По умолчанию LAG использует только один из портов, для передачи информации, второй остается в качестве резерва.

Нужно явно указать коммутатору применять балансировку нагрузки к port-channel

Делается это командой

Port-Channel load-balance src-dst-mac-ip-port

Причем, достаточно прописать эту команду на одном из коммутаторов!

Снова запускаем, здесь и далее я буду обрезать вывод iperf3, показывая только результат:

iperf3.exe -c 100.64.0.8 -b 10G -P 10
[SUM]   0.00-10.00  sec  2.20 GBytes  1.89 Gbits/sec                  sender
[SUM]   0.00-10.00  sec  2.20 GBytes  1.89 Gbits/sec                  receiver

Ура, достигнута нужная скорость.

Проверим, что будет если мы отключим кабель из 22 порта на коммутаторе.

В нашем случае потерялся только один пакет:

В нашем случае потерялся только один пакет:
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128
Превышен интервал ожидания для запроса.
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128
Ответ от 100.64.0.3: число байт=32 время<1мс TTL=128

Проверим скорость:

iperf3.exe -c 100.64.0.8 -b 10G -P 10
[SUM]   0.00-10.00  sec  1.11 GBytes   949 Mbits/sec                  sender
[SUM]   0.00-10.00  sec  1.10 GBytes   948 Mbits/sec                  receiver

Ожидаемо скорость упала до 1 Гбит/с.

Давайте добавим еще 2 линка в наш лаг, для этого пропишем на верхнем и нижнем коммутаторах:

config
interface range GigabitEthernet 1/0/20-21
channel-group 1 mode auto
ex

Соединим коммутаторы дополнительно через порты 20 и 21

Проверяем скорость:

iperf3.exe -c 100.64.0.8 -b 10G -P 10
[SUM]   0.00-10.00  sec  4.38 GBytes  3.76 Gbits/sec                  sender
[SUM]   0.00-10.00  sec  4.38 GBytes  3.76 Gbits/sec                  receiver

Что и нам и требовалось. В принципе таким образом мы можем увеличить ширину канала между коммутаторами до 8 Гбит/с, так как в одном LAG может быть максимум 8 портов.

Я не тестировал, но, теоретически, возможно, задействовав еще и порт 10G увеличить до 17Gb.

Конфигурация коммутаторов

Верхний:

console#sh ru
!
interface gigabitethernet1/0/20
 channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/21
 channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/22
 channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/23
 channel-group 1 mode auto
exit
!
interface Port-channel1
 description LAG2Gbits
exit
!
interface vlan 1
 ip address 100.64.0.101 255.255.255.0
 no ip address dhcp
exit
!
End

Нижний:

console#sh ru
Port-Channel load-balance src-dst-mac-ip-port
!
interface gigabitethernet1/0/20
 channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/21
 channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/22
channel-group 1 mode auto
exit
!
interface gigabitethernet1/0/23
channel-group 1 mode auto
exit
!
interface Port-channel1
 description LAG2Gbits
exit
!
interface vlan 1
 ip address 100.64.0.100 255.255.255.0
no ip address dhcp
exit
!
end

Заключение

 Сегодня мы рассмотрели настройку LAG между двумя коммутаторами MES2348B.

Вы соединили два сервера к коммутаторам 10G линками, а сами коммутаторы линком 1G.

Проверили связь и скорость передачи данных между серверами.

Настроили LAG между коммутаторами по портам 22 и 23.

Проверили скорость передачи данных между серверами и до настроили коммутаторы, включив на одном из них балансировку нагрузки.

Увеличили количество линков и проверили, как их количество влияет на скорость передачи данных.

Прочитано 384 раз Последнее изменение Четверг, 01 октября 2020 16:41
Другие материалы в этой категории: « Настройка DHCP-сервера на MES2324B