Среда, 24.01.2024 14:15

Установка OpenSSL 3.2.0 в РЕДОС Linux

Установка OpenSSL 3.2.0 в РЕДОС Linux

Сегодня мы рассмотрим установку OpenSSL версии 3.2.0 в РЕДОС Linux. Зачем это нужно?

В комплекте поставки с РЕДОС идет версия OpenSSL

OpenSSL 1.1.1q  FIPS 5 Jul 2022

Хотя этого и достаточно для работы операционной системы, но новые версии QtCreator собираются с OpenSSL версии 3, которая пришла на смену OpenSSL 1.x.x.

В предыдущей статье - Установка QtCreator 12.0.1 в РЕДОС Linux мы установили QtCreator 12.0.1 в РЕДОС Linux и в целом всё работает.

Откроем консоль и запустим:

qtcreator

Давайте попробуем открыть меню

Правка – Настройки

Выберем Устройства и нажмем Настроить SDK

1

Нажмем настроить SDK и нажмем Да

2

Получим ошибку:

Не удалось загрузить Android SDK Tools из https:// ... : Не удалось инициализировать TLS.

Если же мы взглянем в консоль, то увидим множественные сообщения об ошибках:

qt.tlsbackend.ossl: Incompatible version of OpenSSL (built with OpenSSL >= 3.x, runtime version is < 3.x)
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslKey
qt.network.ssl: Active TLS backend does not support key creation
qt.network.ssl: The backend "cert-only" does not support QSslSocket
qt.network.ssl: The backend named "cert-only" does not support TLS
qt.network.ssl: QSslSocket::connectToHostEncrypted: TLS initialization failed

Проверим версию OpenSSL:

/usr/bin/openssl version
OpenSSL 1.1.1q  FIPS 5 Jul 2022

У нас установлена версия 1.1.1q, в то время как QtCreator 12.0.1 собран с версией 3.x.x!

Нам нужно установить OpenSSL версии 3!

Установка OpenSSL 3.2.0

Создадим рабочую папку:

Создадим папку:

mkdir ~/openssl3
cd ~/openssl3

Загрузим исходный код:

wget https://github.com/openssl/openssl/releases/download/openssl-3.2.0/openssl-3.2.0.tar.gz

Распакуем:

tar xzvf openssl-3.2.0.tar.gz

Запустим конфигурирование:

cd openssl-3.2.0
./config --prefix=/usr/local/ssl --openssldir=/usr/local/ssl shared zlib

Запустим сборку и установку

make
su
make install

Создадим файл /etc/profile.d/ssl3.sh

mcedit /etc/profile.d/ssl3.sh

С содержимым:

PATH=/usr/local/ssl/bin:$PATH
export PATH

LD_LIBRARY_PATH=/usr/local/ssl/lib64:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH

Перезагрузим:

reboot

Проверим:

openssl version
OpenSSL 3.2.0 23 Nov 2023 (Library: OpenSSL 3.2.0 23 Nov 2023)

Обратите внимание, после того как мы добавили новую папку в PATH запускается новая версия openssl!

Проверим:

whereis openssl
openssl: /usr/bin/openssl /usr/include/openssl /usr/local/ssl/bin/openssl /usr/share/man/man1/openssl.1ssl.gz

Старая версия никуда не делась, просто в приоритете теперь новая.

Запустим qtcreator еще раз, зайдем в Правка – Настройки и нажмем на Настроить SDK

Ошибка исчезла и сразу начинается загрузка:

3

Далее я не буду рассматривать установку JDK, NDK и прочих библиотек для разработки под Android, но обязательно к этому вопросу вернусь в одной из будущих статей!

Заключение

Сегодня мы рассмотрели установку OpenSSL 3.2.0 в РЕДОС Linux:

Загрузили исходный код;

Собрали собрали и установили OpenSSL 3.2.0 из исходного кода.

Категория Red Linux

Добавить комментарий

Простой текст

  • HTML-теги не обрабатываются и показываются как обычный текст
  • Строки и абзацы переносятся автоматически.
  • Адреса веб-страниц и email-адреса преобразовываются в ссылки автоматически.
Просмотров: 44